Resolved
Maps are operating, as intended, and displaying correctly for Android devices.
Monitoring
A fix has been implemented and we are monitoring results.
Identified
We have identified a solution, completed the fix and will begin rolling it out to users.
Identified
Maps are not displaying on the All Drives screen for Android devices. To access map information about drives, please use the web app (dashboard.mileiq.com).