Creating Reports Temporarily Unavailable

Incident Report for MileIQ

Resolved

This incident has been resolved and we are communicating to impacted users.
Posted Nov 26, 2024 - 16:22 PST

Monitoring

A fix has been implemented and we are monitoring results.
Posted Nov 26, 2024 - 13:50 PST

Investigating

We are currently experiencing an issue with creating reports. Our team is working hard to resolve this as soon as possible. We apologize for the inconvenience.
Posted Nov 26, 2024 - 11:49 PST