We're currently experiencing drive processing delays.

Incident Report for MileIQ

Resolved

This incident has been resolved.
Posted Jul 12, 2022 - 15:09 PDT

Monitoring

We're observing return to normal near real-time processing for drives.
Posted Jul 12, 2022 - 14:53 PDT

Investigating

All your drive data is saved and will be processed as we work with our maps provider to fix the issue.
Posted Jul 12, 2022 - 14:11 PDT
This incident affected: iOS App, Android App, and Web App.